Jump to content

DOO 1.15 (Extending Connectivity to LaaS


Recommended Posts

be aware that in my exam they changed the question

"Extend IPV4 and IPV6..."

So the solution I saw was this:

 

On r11

interface gigabitEthernet 0/0

 ipv6 address 2001:2710:311::2/64

 

route-map NHv6 permit 10

 set ipv6 next-hop 2001:2710:311::1

 

router bgp 65001

 address-family ipv6

 redistribute eigrp 65001 include-connected

 neighbor 100.3.11.1 activate

 neighbor 100.3.11.1 route-map NHv6 in

 

router eigrp ccie

 address-family ipv6 unicast autonomous-system 65001

 topology base

 redistribute bgp 65001 metric 10000 1000 255 1 1500

On r3

vrf definition fabd2

                route-target export 10000:3681

 route-target import 10000:414

 address-family ipv6

 

 

interface gigabitEthernet1

 ipv6 address 2001:2710:311::1/64

 

route-map NHv6 permit 10

 set ipv6 next-hop 2001:2710:311::2

 

router bgp 10000

               address-family ipv6 vrf fabd2

 neighbor 100.3.11.2 remote-as 65001

 neighbor 100.3.11.2 activate

 neighbor 100.3.11.2 route-map NHv6 in

 

 r4

interface loopback0

               ip address 100.255.254.4 255.255.255.255

 

vrf definition giosk

               route-target import 10000:3681

 

Any comments?

 

 

  • Like 1
Link to comment
Share on other sites

Thank you for the response, I see the someone configured as below but don't understand why.

 

R3:
vrf definition fabd2
 rd 10000:1
 route-target export 10000:1
 route-target export 10000:3681
 route-target import 10000:1
 route-target import 10000:414
 route-target import 10000:4
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family

R4:
vrf definition fabd2
 rd 10000:4
 route-target export 10000:4
 route-target import 10000:4
 route-target import 10000:3681
 !
 address-family ipv4
 exit-address-family
vrf definition giosk
 rd 10000:414
 route-target export 10000:414
 route-target import 10000:414
 route-target import 10000:3681
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family

Link to comment
Share on other sites

well this is what you will find on the exam:

 

rf definition fabd2
 rd 10000:1
 route-target export 10000:1
 route-target import 10000:1
 route-target import 10000:414
 

the question say: if you need to use a RT use 3681.

So I´m not sure if it will be correct using the 414 - even if it is already exists.

In the question says cleary 'use 3681' - it does not say you can use existing RT and 3681.

Basically we can archive every ing using just an RT 3681 - I have tested many times in my lab and I receive the IAAS prefixes in HQ as R4 receives the prefixes from HQ

Just make sure to read the question as previous only stated IPv6 but now it is stated 'extend IPv4 and IPv6 prefixes'

  • Like 1
Link to comment
Share on other sites

Importing 10000:1 in R4 will import all the routes from branch 3 and 4 too. That will break the requirements. They say something about only importing from HQ fabd2 sites

Edited by KANS
  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
On 4/8/2023 at 5:06 AM, zeMas said:

well this is what you will find on the exam:

 

rf definition fabd2
 rd 10000:1
 route-target export 10000:1
 route-target import 10000:1
 route-target import 10000:414
 

the question say: if you need to use a RT use 3681.

So I´m not sure if it will be correct using the 414 - even if it is already exists.

In the question says cleary 'use 3681' - it does not say you can use existing RT and 3681.

Basically we can archive every ing using just an RT 3681 - I have tested many times in my lab and I receive the IAAS prefixes in HQ as R4 receives the prefixes from HQ

Just make sure to read the question as previous only stated IPv6 but now it is stated 'extend IPv4 and IPv6 prefixes'

Hi zeMas,

Do you have any update workbook. Can you share to me. Thank you so much. I am working on workbook from 2021 that shared on forum.

 

Link to comment
Share on other sites

  • 2 weeks later...
On 4/8/2023 at 4:29 AM, zeMas said:

be aware that in my exam they changed the question

"Extend IPV4 and IPV6..."

So the solution I saw was this:

 

On r11

interface gigabitEthernet 0/0

 ipv6 address 2001:2710:311::2/64

 

route-map NHv6 permit 10

 set ipv6 next-hop 2001:2710:311::1

 

router bgp 65001

 address-family ipv6

 redistribute eigrp 65001 include-connected

 neighbor 100.3.11.1 activate

 neighbor 100.3.11.1 route-map NHv6 in

 

router eigrp ccie

 address-family ipv6 unicast autonomous-system 65001

 topology base

 redistribute bgp 65001 metric 10000 1000 255 1 1500

On r3

vrf definition fabd2

                route-target export 10000:3681

 route-target import 10000:414

 address-family ipv6

 

 

interface gigabitEthernet1

 ipv6 address 2001:2710:311::1/64

 

route-map NHv6 permit 10

 set ipv6 next-hop 2001:2710:311::2

 

router bgp 10000

               address-family ipv6 vrf fabd2

 neighbor 100.3.11.2 remote-as 65001

 neighbor 100.3.11.2 activate

 neighbor 100.3.11.2 route-map NHv6 in

 

 r4

interface loopback0

               ip address 100.255.254.4 255.255.255.255

 

vrf definition giosk

               route-target import 10000:3681

 

Any comments?

 

 

I think if they ask only for ipv6 your config should be good

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...