Jump to content
×
×
  • Create New...

Task 1.8: OSPFv2 in DC


Recommended Posts

The solution I have seen appears incorrect around the vedges. Simply changing the MTU does stabilize the neighbor ship between vedge and vlan 3999 however all or most of the routes learned at the vedge on vpn999 become inactive. Does it violate condition of the task to change the OSPF process for vlan3999 and perform a mutual redistribution between the new process and the existing process to solve this task?

Link to comment
Share on other sites

"Do not redistribute unless specifically told to" - From the exam rules

 

I would suggest configuring the mtu and shut/no shut on the vlan 3999. This should stabilize the routes. 

Edited by smak
Link to comment
Share on other sites

FYI - there's an issues around OSPF if the RID for the vEdge is the same for both VPN 999 and VPN 0.


I highly suspect this is the instability you talk about, and this is not a problem in the exam.

Link to comment
Share on other sites

@MrPlinkett, I ran across something similar to this in my last lab. Once I had prefix suppression enabled at DC, the vEdge was not advertising routes that it received from upstream IOS neighbors. What I found was that if the upstream IOS devices connected to vEdge were the DR and BDR in VLAN 3999, prefix-suppression was causing the vEdge to not advertise routes it received. 

If I flipped the OSPF priority on the sw201 and sw202 so they would never become DR/BDR, and the vEdges took over as the DR and BDR, everything went back to normal, and the vEdges advertised routes into OMP from DC.

According to the OSPF RFC for prefix-suppression, PS enabled devices connected to NON-PS enabled devices shouldn't run into issues like this. But it seems to be happening nonetheless...

 

  • Thanks 1
Link to comment
Share on other sites

Exact same thing happened to me in the first lab - where I was missing certain routes from the SD-WAN site across VPN 999.

Similar to you, I bounced the VLAN interface and that seemed to fix the problem. Tragically I only had 5 minutes left on the lab.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share